If you install Tomcat8 (even tomcat7) via apt you will need to edit the file /etc/default/tomcat8   (or tomcat7) and look for the JAVA_OPTS variable. The Xmx value is there and you can set it as required.